News

Know about market updates

apache ant 다운로드

아파치 Ant 팀은 현재 두 라인의 개발을 유지 한다. 1.9. x 릴리스에서는 런타임 시 Java5 필요 하며, 1.10. x에서는 런타임에 Java8 필요 합니다. 두 라인은 개미 1.9.7의 기반과 1.9. x 릴리스는 추가적인 새로운 특징이 1.10. x .을 위해 개발 된 동안 주로 버그 난관 릴리스 이다. 빌드 프로세스 중에 Java8 하기 전에 Java 버전을 사용 해야 하는 경우가 아니라면 1.10. x를 사용 하도록 권장 합니다. 많은 제안이 소프트웨어의 잠재적인 두 번째 버전에 대 한 떠오르고 있지만, 상수 메모에 아파치 개미 업데이트, 연간 세 가지 새로운 반복의 평균.

이 속도로, 그들은 2016에 의해 소프트웨어의 두 번째 버전을 공격에 바인딩됩니다. 제쳐두고 이야기의 익살 스러운 부분을 떠나, 아파치 개미 처럼 보이는 그 일 번호가 매겨진. 자바 1.4는 지금 일요일까지 풀어 놓 이다. 최신 아파치 Ant 소스는 소스 애 트리 뷰트를 통해 컴파일러 태스크에서 새로운 assert 명령문을 지원 한다. 또한 Windows XP를 통한 Java 1.4의 일부 ant 태스크에 필요한 호환성 픽스도 포함 되어 있다. 당신은 WinXP/Java 1.4에 개미 1.4.1을 실행 하는 데 문제가 있는 경우, 최근 빌드를 사용 하거나 소스 트리에서 자신의 버전을 컴파일합니다. 아파치 아이비 2.4.0 지금은 소스 또는 이진 (와 의존성 없이) https://ant.apache.org/ivy/download.cgi에서 다운로드할 수 있습니다. 이것은 아파치 소프트웨어 재단에 의해 호스팅되는 프로젝트 이후 안정적인 것으로 간주 첫 번째 릴리스입니다. 아파치 개미, 아이비, Ivyde, antlibs 및 easyant의 소스 코드는 모두 Git로 마이그레이션됩니다. 우리는 뿐만 아니라 샌드 박스, Subversion을 우리의 웹 사이트를 유지 하 고 있습니다.

아파치 ant 프로젝트는 별도의 다운로드 된 ant 라이브러리로 사용할 수 있는 추가적인 태스크와 타입도 제공 한다. 당신은 개미 도서관 페이지에서 사용할 수 있는 antlibs의 목록을 볼 수 있습니다. 이 릴리스는 아파치 코몬즈 압축의 1.4 릴리스에 적응 하 고 지금 XZ 형식에 대 한 지원을 추가 하 고 현재 POSIX 표준에 대 한 제한 된 지원을 포함 하 여 타르 방언의 넓은 다양 한 지원 합니다. 당신이 위의 비슷한 메시지를 본다 면 아파치 개미가 윈도 즈 (위)에 성공적으로 설치 된다는 것을 의미 한다. 아파치 개미는 그의 임무가 서로에 의존 하는 목표와 연장 점으로 파일을 건설 하기에서 기술 된 과정을 몰 것 인 자바 도서관과 커맨드 라인 공구 이다. 개미의 주요 알려진 사용법은 자바 신청의 구조 이다. Ant는 자바 애플리케이션을 컴파일, 조립, 테스트 및 실행할 수 있는 많은 내장 태스크를 제공 한다. 개미는 또한 예를 들면 c 또는 c + + 신청을 위한 비 자바 신청을, 건축 하기 위하여 효과적으로 이용 될 수 있다.